Link verification seems broken

Incredibly insignificant thing, but reporting it anyway: on Mark Cornick :mastodon_oops: ( -, the link to should be verified (i.e. green) since the link back to Mastodon with rel=“me” is on the page. The other links there are all green, it’s just this particular one that seems broken. Any ideas?

1 Like

In the past when this has happened, it could usually be resolved by editing your profile, making a small change (e.g. to the bio), and saving it. Mastodon only tries to fetch and evaluate the links on your profile when the profile is actually changed in some way. So, usually doing this a couple of times was enough to get it to actually pull up the page and take a look (and then apply the green treatment when it found what it was looking for).

But now I worry that using might be interfering, though in theory it shouldn’t. I enabled it a couple of days ago (more info on that here).

Can you try the “profile jiggle” that I described above and see if that helps? If it doesn’t, we can go from there (the likely next move would be to try disabling the jort redirection to see if it makes a difference).

Still seems stuck - I’ve edited the bio a few times, and edited the link in question (changing from to and back - they both go to the same place) and still no green. This did work when I first added the link a few weeks back.

Not a big deal. But thanks for looking at it!

Thanks for trying — I’ve just disabled the setup, so feel free to give it another jiggle and we’ll see if it makes a difference!

OK, that did it. All links green now. But the stuff sounds really useful and not worth disabling just to get green links. Don’t keep it disabled just to make me happy. :slight_smile:

1 Like

Good to know that’s the culprit! I’ve turned it back on, but yeah, I suspect whenever people edit their profiles it will cause more problems. I’ll look into other options for working around this and making things more reliable.

1 Like

Just stopping by to say I’ve learned my lesson the hard way to check the discourse before banging my head against a problem alone…

I still can’t get any variation/combination/switchboard version of my profile URL to verify on Mastodon.

If this is because the above issue hasn’t been resolved yet, I’m not complaining at all, I just wanted to check and see whether it’s the ongoing issue or something I’m doing wrong.

1 Like

It could very well be related to the above issue, though it’s hard to say — even before using, the Mastodon link verification process was frustratingly opaque and pretty much impossible to troubleshoot effectively. I did just go ahead and disable, though, so if you want to edit your profile (just make any small change, save it, and then revert back) that should trigger a re-check of the links for verification. Let me know if you continue to have trouble with it, though!

Not sure if I was too late and you turned Jort back on before I tried, but it still wasn’t verifying a moment ago. It’s no big deal, and, as you said, verification is kind of all over the place.

UPDATE: So I was putzing around some more, as I so often do, and decided to try my omg referral link, which I saw verified in someone else’s profile (Merlin Mann). Turns out that my referral link does verify, even though every other omg profile URL I tried via the switchboard would not.

It’s still disabled, so we can dig a little deeper… What’s the URL that you’re trying to verify?

Having the same issue with when verified from

@vmstan, @joeross, try making a small edit to your Mastodon bios/profiles and saving — which should trigger a re-check. I thought I had all of the Jort config fully disabled, but it turns out that I didn’t (I discovered this when I started curling stuff with a Mastodon user-agent to see what in tarnation was going on). Should be 100% good to go now.

I am so sorry about that! :prami_distressed:

Putting this here in case future me or anyone else has to come back for any troubleshooting… this was the command I was using (this one specifically was for looking at @vmstan’s setup):

curl -A "http.rb/5.1.1 (Mastodon/4.1.2; +" --verbose | grep 'rel="me" href=""'

It’ll show exactly the line that Mastodon is looking for when performing a link verification. Before I finally fixed the Jort stuff, it was showing nothing at all. Now it’s good!

Yep. All good now.

1 Like

Same here, thanks @adam!

1 Like