External domain not redirecting to weblog

I was wondering if someone could tell me what I’m doing wrong with my external domain forwarding? I have my external domain approved and working, but trying to get it to forward to my weblog gives me the result ‘site not configured’.


I’ve watched this video here (Webpage on the root domain and weblog on a subdirectory - #2 by adam) and attempted to do the same thing, and I get this response:

It does not change what my external domain says.

This is what I typed, pretty sure I don’t have any errors but you never know:

Now, I did have a landing page set up to go to /ivysdesk so I thought maybe that was my problem and changed the location from ‘Location: /’ to ‘Location: /ivysdesk’ but that didn’t work, and neither did removing the landing page and any custom url/configuration at all.

I feel like I’m missing something really obvious, but I just can’t seem to make sense of it. Any help would be appreciated!

1 Like

You’ve discovered a bug! I had never tested the specific condition that you created here, with a “File” entry being served as the weblog root, and I had some other code that was preventing that from working as intended. It’s fixed now, so this should work (though it looks like your File entry is gone now — but if you add it back, you can serve it from the root location / now!).

Thanks for the quick response! I did go back and try again, but I’m getting the same results. I also tried copy and pasting the source like you did for your profile in the video and it had the same results. Is there anything else I can try?

Out of curiosity, do you have a Landing page value defined in your configuration?

Yes, it’s Landing page: /ivysdesk which is why I thought maybe making the location of the file Location: /ivysdesk might fix it, but alas… is that my problem?

1 Like

Ah, I think that’s your culprit then! When you define a landing page in the config, the weblog engine will look for an entry with a matching location to serve. So if there’s no post with a Location value of /ivysdesk (or no post with a title that would translate to that particular slug), it’ll throw a 404. To fix this, just remove or comment out that line in your config, and then requests for the weblog root will be handled by a matching entry, which in your case would be the file you showed earlier with a the metadata Location: / (assuming you put that back).

Hope this makes sense! Let me know if it doesn’t, or if you’re still stuck.

I tried that, and while it doesn’t break the original link to the weblog anymore, it still is telling me that the site isn’t configured when I try my external domain. Out of curiosity, I tried setting it up so that it would go to my profile page and tried selecting the redirect to a URL and then pasting the weblog URL and all returned the same ‘site not configured’ response. I’m sorry for all the trouble! Thank you for taking your time to help me with this!

@Adam I am so sorry, I am such a dummy. I forgot to add https:// to the front of my domain! As soon as I did all worked exactly as it was supposed to. I am so sorry for wasting your time, thank you for all your help.

1 Like

Heh, you didn’t waste any of my time, don’t worry! I’m glad that you were able to get it sorted out. :slightly_smiling_face:

1 Like